
H E A D I N G S  &  T O C S  I N  W O R D  2 0 0 7  

HEADINGS & TOCS IN WORD 2007 
MODUS OPERANDI WORD TRAINING 

Prepared by:  Karen Dyson 

07-August-2009 

 

ABSTRACT:   
This training session teaches you how to control how headings look and 
how to use automatic features such as numbering.  By using these 
features the way the designers intended, you can accomplish the 
following: 

• Create a consistent look throughout the document, 
• Automatically number headings, 
• Create a table of contents, and  
• Refer to numbered sections in your document. 

If you let Word worry about the numbering, then you won’t have to worry 
about making errors in numbering and referring to sections.  
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UNDERSTANDING WORD’S CONCEPT OF HEADINGS 
A style is a set of formatting characteristics, such as font name, size, 
color, paragraph alignment and spacing.  When you use styles to format 
your document, you can quickly and easily apply a set of formatting 
choices consistently throughout your document. 

A heading is a type of built-in style that has an associated outline level.   
When you use Word’s built-in heading styles, you can take advantage of 
the following features: 

• Generate a table of contents automatically. 
• Automatically number sections in your document. 
• Insert cross-references to other numbered sections of your 

document. 
• Display a document map (the Word analog to PDF bookmarks.) 
• Generate bookmarks when saving in the PDF format. 

USING A BUILT-IN HEADING STYLE 

 

The Style Gallery on the Home tab provides quick and easy access to 
built-in styles. 

The Style Gallery

It is so much easier to (1) use a built-in heading style, if you want to be 
able take advantage of the features listed above, than to (2) use custom 
styles you create from scratch, that we’re not even going to talk about 
the second option!  You can change the look of a built-in style just as you 
can change the look of custom styles, so don’t let the need for creative 
expression prevent you from starting with a built-in heading style. 

There are several ways to choose a built-in style.  Start by typing in the 
text that will be a heading and hit the ENTER key to indicate the end of 
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the paragraph.  Then select the whole paragraph or simply place your 
cursor anywhere within the paragraph text.  Select a style by either of the 
following methods: 

 

The Styles Window is opened by clicking the small arrow at the lower 
corner of the Styles area of the Home tab.  It is usually docked to the 
right of your open document.  By default it displays recommended 
styles, but you can change its display options (lower right corner of 
window), for example, to list styles in Alphabetical order. 

• Click a Heading Style in the Style Gallery [see the picture on the 
previous page]. 

- OR -  

• Select a style from the Styles Window.  To display the Styles 
Window, select the small arrow at the bottom corner of the Styles 
area of the Home tab. 

The contents and arrangement of the Style Gallery and Styles Window 
are controlled by a number of display options.  For example, the styles 
may be sorted in recommended order.  The display options are accessed 
from a link at the bottom of the Styles Window. 

OUTLINE LEVELS 

Headings are associated with outline levels.  Outline levels are a way to 
logically organize the contents of your document into chapters, sections 
and subsections.  If you view your document in outline mode, you’ll be 
able to collapse and expand its contents.  Therefore, headings are 
hierarchical with a parent/child relationship, and Heading 1 is the top 
level parent. 
 
Heading 1 
 Heading 2 
  Heading 3 
   Heading 4 
    Heading 5 
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Does every heading have to belong to a parent at a higher outline level?  
No.  You could begin your document with an orphaned heading style with 
no parent heading style of a higher level (such as a Heading 2 with no 
parent Heading 1).  And that’s okay.  Unless you are following a formal 
document format (such as a technical report), are numbering document 
sections, or will be creating a table of contents, it does not matter. 
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CONTROLLING WHETHER HEADINGS ARE NUMBERED 
The default built-in heading styles are not numbered.   It is very easy to 
change that.  In doing so, you may notice one of the special ways that 
Word handles heading styles. 

 

Word’s default heading styles are not 
numbered (above).  An example of 
outline-numbered headings is shown 
below. 

 

WARNING: A change to one Heading style may result in changes to 
other Heading styles. 

AUTOMATICALLY NUMBERING HEADINGS 

The most common way to number headings is outline numbering as 
illustrated by the following example. 

1. Heading 1 
1.1. Heading 2 
1.2. Heading 2 

1.2.1. Heading 3 
1.2.2. Heading 3 

2. Heading 1 
3. Heading 1 
You can use the following approach regardless of how many headings 
are in your document, and Word will number all of the headings.    

To number your headings, use the following steps: 
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b. Select any heading in your document. 

c. Select the multi-level list style from the List Library shown at left.  
Word will immediately number all heading styles.   

This particular built-in multi-level list style associates each list level with a 
heading style (and thus an outline level). By default, it has no left 
indentations.  Numbered headings with no left indentations are common 
in documents such as technical reports, specifications and statements of 
work.  You can modify indentations for heading styles as you would for 
any other paragraph style. 

REMOVING HEADING NUMBERING 

The first time you number headings, it is global, i.e., it applies to all 
headings in the document. However, if you later want to reverse this 
change and remove numbering of your headings your change is local to 
the selected paragraph.  To globalize the change, it takes more work.  
You have to modify each heading style individually. 

To remove heading numbering, use the following steps. 

a. In a paragraph of Heading 1 style, 

b. Right-click in the paragraph, and select from the drop down menu as 
follows:  Numbering > Select the style None in the Numbering 
Library. - OR - 

c. Click and select None in the multi-level List Library in the Home tab > 
Paragraph area of the ribbon. 

d. Right-click in the paragraph, and select from the drop down menu as 
follows:  Styles > Update Heading 1 to Match Selection. 

 

This multi-level list style is used for numbering headings.  The 
multi-level List Library is located in the Paragraph area of the 
Home tab. 
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e. Repeat for Heading 2, Heading 3, etc. 
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CREATING A TABLE OF CONTENTS 
A table of contents (TOC) is a list of headings and the page number 
where each heading occurs.  It is typically placed at the beginning of a 
document.  Each item in the TOC acts like a hyperlink to that part of the 
document; when you hover over the TOC, a tool tip pops up that 
instructs you to CTRL+CLICK to jump to the location. 

 

A table of contents is automatically generated based on the 
headings in your document. 

WARNING:  If you edit text within the table of contents field, your 
changes will be lost the next time that field is updated. 

INSERTING A TABLE OF CONTENTS 

When a TOC is automatically created by Word, it is essentially one large 
field.  You control the location of the TOC by selecting the insertion point. 

RECOMMENDATION: Viewing the TOC and paying attention to the 
indentations is a good way to visually check that 
your heading styles are at the intended level. 

To insert a TOC, use the following steps: 

a. Place your cursor at the desired insertion point.  A good choice is at 
the beginning of a paragraph of Normal style. 

b. Select Table of Contents from the References Tab. 

c. Pick one of the Automatic Table styles from the drop-down menu. 
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Word will insert the TOC. 

You can have more than one TOC in a document, but the designers of 
Word made it difficult to do so because it is uncommon.   (Instructions 
not included here—just know that it can be done).  Therefore, if you 
select the Table of Contents command again, your selection will be 
applied to the existing TOC.  If you want to move it, you can cut and 
paste the TOC field to a new location, or delete it and insert a new one. 

UPDATING A TABLE OF CONTENTS 

After you insert a TOC, Word will not keep it up to date with every 
change you make to your document.  To update it, you simply right-click 
anywhere in the TOC field and select Update Field. 

RECOMMENDATION: Force Word to update the Table of Contents by 
invoking an update command; do not assume 
that Word will update it.  View the results, for 
example, to ensure that it did not grow larger 
than you were expecting. 

CONTROLLING WHAT APPEARS IN THE TABLE OF 
CONTENTS 

By default, Heading levels 1, 2 and 3 will appear in your TOC.  If you 
want to go deeper and include additional heading styles, you can select 
them from the Table of Contents Options dialog.  To see these options, 
select Insert Table of Contents from the Table of Contents drop 
down menu. 
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an Automatic Table style, from the Table of Contents menu, you 
will get more control over how it looks.  The options dialog allows 
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If you are editing a document containing a TOC created by someone 
else, you may find it contains styles that you don’t want to include.  If so, 
you can remove them by clearing the TOC level field in this dialog. 

CONTROLLING HOW THE TOC LOOKS 

Each TOC level is associated with a corresponding paragraph style:  
TOC 1, TOC 2, TOC 3, etc.  You will see those styles appear in your 
Styles Window. 

The easiest way to change the appearance of the TOC is to select one 
paragraph within the TOC field and change it.  The style change will be 
automatic and should be immediate; i.e., all paragraphs at the same 
TOC level will match it.  This happens because TOC styles are set to 
‘Automatically update’ by default. 

Sometimes the change you made does not immediately cause the 
display to be refreshed so that you can see your change ripple through 
the entire TOC.  In that case, try updating the TOC field, and choose to 
Update entire table (as shown at left).  That should do the trick.   

If this does not work, it could be that the TOC style settings were 
modified and the ‘Automatically update’ setting was turned off.  In that 
case, you must modify the TOC styles from the Styles Window. 
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Default TOC styles (above) and customized styles (below). 

 

 

Update the entire table to see the latest contents, and to see the 
effect of any style changes you have made. 
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REFERRING TO NUMBERED SECTIONS 
A cross-reference is a field that refers to a thing with a number or label, 
such as a heading, a figure or a table in your document.  Cross-
references are like pointers; they will keep pointing to the same thing 
even if that thing’s label or number changes. 

RECOMMENDATION: Use a cross-reference to refer to numbered 
sections in your document.  That way, you won’t 
have to worry about whether the numbers are 
correct as you edit the document.  The longer 
your document, the more important this is. 

INSERTING A CROSS-REFERENCE 

When you insert a cross-reference, you can insert the number, or the 
label (text), or both.  For headings, it takes two steps to insert the 
number and the text as in the top example at left.  Just as with the 
numbers, if you want the heading text to appear in the reference, it is 
much better to insert a cross-reference than to type in the text.  That 
way, if you later edit the heading text, you won’t have to worry about  
making every reference to it match. 

To insert a cross-reference to a numbered heading , use the following 
steps. 

a. Place the cursor at the insertion point. 
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Here are some examples of cross-references.  Since they are fields 
that are automatically filled in by Word, they are displayed with gray 
shading. 

 

The Cross-reference command is in the Captions area of the 
References tab. 
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b. Select the Cross-reference command on the References tab.  
Word will open the Cross-reference dialog. 

c. Select Heading from the Reference type list. 

d. Select Heading number from the Insert reference to list. 

e. Click Insert to finish.  Word will then insert a cross reference field.   

If you want the text to appear, you must select Heading text from the 
Insert reference to list and click Insert again.  Then you can insert a 
space or punctuation between the number and the text. 

UPDATING REFERENCES 

Right-click a field to see the Update Field command.  That 
command only updates the selected field, however. 

Just as with a TOC field, Word does not update cross-reference fields 
every time you make a change in your document.  You must trigger the 
update in one of the following ways. 

• Update one field at a time, by right clicking in the field and 
selecting Update Field. 
- OR - 

• Select a portion of your document and then hit F9. 

WARNING:  Updating may not work well if you have Tracked Changes 
in your document, and the changes include cross-reference 
fields or referenced items.   You may have to first Accept All 
Changes and then update the fields. 
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DON’T PANIC – TROUBLESHOOTING GUIDANCE 
In this section, we will discuss the likely causes of, and how to recover 
from, four common problem situations. 

• Problem #1:  Heading styles are really messed up. 

• Problem #2:  The table of contents has extra stuff in it. 

• Problem #3:  The table of contents is too spread out. 

• Problem #4:  The reference number isn’t correct. 

PROBLEM #1:  HEADING STYLES ARE REALLY 

MESSED UP 

Messed up how?  We’ll discuss some common symptoms and how to 
recover. 

1. Inconsistency .  This means that headings with the same style 
don’t all look the same, and you expect them to look the same.  
For example, some are numbered and some are not, or some 
use a different font. 

2. Applying a style doesn’t seem to work.  Selecting a style from 
the gallery or Styles Window doesn’t change the characteristics 
of the heading the way you expect. 
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3. Can’t get back to the template style.  You’ve altered the style 
and want to revert back to what it was in the template, but can’t 
figure out how to get back. 

INCONSISTENCY 
This symptom is usually an indicator that you’ve made a change to 
individual heading paragraphs (i.e., a local change) and have not 
modified the Heading style (i.e, to make it global). 

To recover, use the following steps for each Heading level that has an 
inconsistency problem. 

a. Select a heading paragraph that has the style you want by placing 
the cursor anywhere in that paragraph. 

b. Right-click in the paragraph, and check the options under Styles in 
the drop-down menu. 
• If Update Heading N to Match Selection appears, then 

‘Heading N’ will be the base style that you started with and 
diverged from.   Go ahead and select that option.  Word will 
modify the base style to match your selected heading. 

• If it doesn’t list a Heading N style here, then that means that the 
paragraph wasn’t a heading.  In that case, don’t select an option 
under Styles.  Instead exit the drop down menu without making 
a selection.  Select the desired Heading style from the Style 
Gallery or Styles Window. 

APPLYING A STYLE DOESN’T SEEM TO WORK 
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If you try to apply a style to a paragraph and that doesn’t make it look like 
the selected style, then the most likely cause is that local changes that 
you made to the paragraph are overriding the style. 
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To recover, you need to first get rid of any local changes and then apply 
the desired style.  Use the following steps to achieve that. 

a. Select the heading paragraph. 

b. Select Clear All from the top of the Styles Window.  The paragraph 
will revert to Normal style. 

c. Select the desired heading style. 

RECOMMENDATION: Clear All is a good all-around cure for style 
woes, because it reverts to the simplest known 
state:  the Normal style. 

CAN’T GET BACK TO THE TEMPLATE STYLE 
Suppose you’ve been editing a document based on a ‘template’ that 
contains custom styles designed by someone else.  You’ve altered the 
heading styles, but now want to get back to what they were before you 
made changes.  You’ve made too many other edits to use the Undo 
command.  What do you do? 

If it is just a few styles that you want to change, then the simplest method 
is to copy and paste an example from the source document and use it to 
modify the styles in your document.  That method is detailed below. 

The Simple Method [RECOMMENDED]: 

a. First make sure your Word Options > Advanced > Cut, copy, and 
paste > Pasting between documents when styles conflict is set to 
Keep Source Formatting. 
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b. In the source document, select a paragraph of the style you want to 
emulate. 
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c. Copy and paste it into your document. 

d. Open the Styles Window. 

e. Select the newly added paragraph. 

f. Select the style you want to change in the Styles Window, right-click 
it and select Update Heading N to Match Selection. 

g. Repeat these steps b, c, e, and f for all styles that you want to 
change. 

There are two other methods that are best performed by expert users. 

Expert User Methods:   

• Change style set method.  If you need to revert all of the styles 
in your document, it is best to do them en masse using the Style 
Set feature.  This involves creating a new Style Set from the 
source document, saving it, and applying it to your document. 

• Importing styles method.  You can import styles from one 
document to another.  That command is found under Manage 
Styles. 

 

PROBLEM #2:  THE TABLE OF CONTENTS HAS EXTRA 

STUFF IN IT 

There are three likely causes for this problem: 
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1. The extra items in the TOC have the wrong style.  For example, 
there are paragraphs in the body of the document that have a 
Heading style, but are not supposed to be headings.  The fix is to 
give those paragraphs the correct style. 

2. The TOC is set to include styles other than Heading 1, 2 and 3.  The 
fix is to modify the TOC Options as described in the 
section Controlling what appears in the Table of Contents. 

3. Someone added text within the TOC field.  The fix is to update the 
field. 

PROBLEM #3:  THE TABLE OF CONTENTS IS TOO 

SPREAD OUT. 

If the TOC takes up too much space, and you don’t want to eliminate any 
of the entries, then the solution is to modify the style of the TOC entries, 
just as you would any paragraph style.    For example, you can reduce 
the font size or reduce the white space between the entries (the 
paragraph spacing).  This is described in the section Controlling how the 
TOC looks. 

The other option is to include fewer heading levels as described in the 
section Controlling what appears in the Table of Contents. 

PROBLEM #4:  THE REFERENCE NUMBER ISN’T 

CORRECT 

If you have inserted a cross-reference to a numbered heading, and the 
number that is displayed is incorrect, the most likely cause is that 
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heading was renumbered and the field has not been updated.   A 
number of editing changes can result in renumbering:  inserting a new 
heading upstream of the referenced heading, changing the heading style 
level, or moving text that contains headings. 

The fix is to update the fields as described in the section Updating 
References. 
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